<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<!--<![endif]-->

<head>
    <meta charset="UTF-8"/>
    <meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0">
    <title>Cheesy Beef Taco Skillet - Andie Mitchell</title>
    <link rel="profile" href="http://gmpg.org/xfn/11"/>
    <link rel="pingback" href="https://www.andiemitchell.com/xmlrpc.php"/>
        <!--[if lt IE 9]>
    <script src="https://www.andiemitchell.com/wp-content/themes/twentytwelve/js/html5.js" type="text/javascript"></script>
    <script type="text/javascript">
        var $buoop = {}
        $buoop.ol = window.onload;
        window.onload = function () {
            try {
                if ($buoop.ol) $buoop.ol();
            } catch (e) {
            }
            var e = document.createElement("script");
            e.setAttribute("type", "text/javascript");
            e.setAttribute("src", "http://browser-update.org/update.js");
            document.body.appendChild(e);
        }
    </script>
    <![endif]-->
    <title>Cheesy Beef Taco Skillet - Andie Mitchell</title>
<script type="application/ld+json">{"@context":"http:\/\/schema.org\/","@type":"Recipe","name":"Cheesy Beef Taco Skillet","author":{"@type":"Person","name":"Andie Mitchell"},"description":"","datePublished":"2020-05-28T09:42:36+00:00","image":["https:\/\/www.andiemitchell.com\/wp-content\/uploads\/2020\/05\/cheesy_beef_taco_skillet-1.jpg","https:\/\/www.andiemitchell.com\/wp-content\/uploads\/2020\/05\/cheesy_beef_taco_skillet-1-500x500.jpg","https:\/\/www.andiemitchell.com\/wp-content\/uploads\/2020\/05\/cheesy_beef_taco_skillet-1-500x375.jpg","https:\/\/www.andiemitchell.com\/wp-content\/uploads\/2020\/05\/cheesy_beef_taco_skillet-1-480x270.jpg"],"recipeYield":"4","prepTime":"PT10M","cookTime":"PT25M","totalTime":"PT35M","recipeIngredient":["2 tbsp chili powder","1 tbsp smoked paprika (optional)","1 tsp ground cumin","1 tsp ground coriander","1 tsp dried oregano","\u00bc tsp cayenne pepper","\u00bd tsp salt","2 tsp olive oil","1  onion, thinly sliced","1  bell pepper (any color), thinly sliced","1 lb 90% lean ground beef","3  garlic cloves, minced","\u00bd cup chicken broth","\u00bd cup canned tomato sauce","1 tbsp Worcestershire sauce (or soy sauce)","2 oz cream cheese","2 oz cheddar cheese, grated (1\/2 cup)"],"recipeInstructions":[{"@type":"HowToStep","text":"In a small bowl, whisk together all spice ingredients. Set aside.","url":"https:\/\/www.andiemitchell.com\/cheesy-beef-taco-skillet\/#wprm-recipe-18263-step-0-0"},{"@type":"HowToStep","text":"In a large skillet, heat the oil over medium heat until hot. Add the sliced onion and bell pepper and cook, stirring occasionally, until softened, about 6 minutes. Transfer to a bowl and return the skillet to heat. Add the ground beef and cook, breaking it up as it browns, until beef is no longer pink, about 5 minutes. Add the garlic and stir for 30 seconds. Add the spice mixture and stir to coat the beef crumbles, about 20 seconds. Return the cooked peppers and onions to the skillet and stir in the tomato sauce, chicken broth, and Worcestershire sauce; bring to a simmer. Reduce the heat to medium-low and simmer, uncovered, stirring frequently, until the sauce has thickened slightly, about 5 minutes. Stir in the cream cheese and cheddar cheese until smooth and melted. Serve with egg noodles or rice or your favorite taco fixings!","url":"https:\/\/www.andiemitchell.com\/cheesy-beef-taco-skillet\/#wprm-recipe-18263-step-0-1"}],"aggregateRating":{"@type":"AggregateRating","ratingValue":"5","ratingCount":"3"},"recipeCategory":["Beef"],"recipeCuisine":["Mexican"],"keywords":"beef taco recipe","nutrition":{"@type":"NutritionInformation","calories":"382 kcal","carbohydrateContent":"12 g","proteinContent":"29 g","fatContent":"24 g","saturatedFatContent":"11 g","cholesterolContent":"104 mg","sodiumContent":"879 mg","fiberContent":"4 g","sugarContent":"5 g","servingSize":"1 serving"}}</script><script>
window.adthrive = window.adthrive || {};
window.adthrive.cmd = window.adthrive.cmd || [];
window.adthrive.host = 'ads.adthrive.com';
window.adthrive.plugin = 'adthrive-ads-1.0.37';
window.adthrive.threshold = Math.floor(Math.random() * 100 + 1);

(function() {
	var script = document.createElement('script');
	script.async = true;
	script.type = 'text/javascript';
	script.src = 'https://ads.adthrive.com/sites/55c23dc7ff03cb3f59927924/ads.min.js?threshold=' + window.adthrive.threshold;
	var node = document.getElementsByTagName('script')[0];
	node.parentNode.insertBefore(script, node);
})();
</script>

<!-- Social Warfare v4.0.1 https://warfareplugins.com -->
<style>
	@font-face {
		font-family: "sw-icon-font";
		src:url("https://www.andiemitchell.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.eot?ver=4.0.1");
		src:url("https://www.andiemitchell.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.eot?ver=4.0.1#iefix") format("embedded-opentype"),
		url("https://www.andiemitchell.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.woff?ver=4.0.1") format("woff"),
		url("https://www.andiemitchell.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.ttf?ver=4.0.1") format("truetype"),
		url("https://www.andiemitchell.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.svg?ver=4.0.1#1445203416") format("svg");
		font-weight: normal;
		font-style: normal;
		font-display:block;
	}
</style>
<!-- Social Warfare v4.0.1 https://warfareplugins.com -->


<!-- This site is optimized with the Yoast SEO Premium plugin v6.3.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://www.andiemitchell.com/cheesy-beef-taco-skillet/" />
<link rel="publisher" href="https://plus.google.com/u/0/+AndieMitchellShow"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Cheesy Beef Taco Skillet - Andie Mitchell" />
<meta property="og:description" content="This easy weeknight dinner is a mash up of two of my great childhood loves: beef tacos and cheesy Hamburger ..." />
<meta property="og:url" content="https://www.andiemitchell.com/cheesy-beef-taco-skillet/" />
<meta property="og:site_name" content="Andie Mitchell" />
<meta property="article:publisher" content="https://www.facebook.com/andiemmitchell/" />
<meta property="article:tag" content="Mexican" />
<meta property="article:tag" content="one pan" />
<meta property="article:tag" content="quick and easy" />
<meta property="article:tag" content="tacos" />
<meta property="article:section" content="Beef" />
<meta property="article:published_time" content="2020-05-28T09:42:36-04:00" />
<meta property="article:modified_time" content="2020-05-28T09:42:40-04:00" />
<meta property="og:updated_time" content="2020-05-28T09:42:40-04:00" />
<meta property="og:image" content="https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-1.jpg" />
<meta property="og:image:secure_url" content="https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-1.jpg" />
<meta property="og:image:width" content="1360" />
<meta property="og:image:height" content="2040" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="This easy weeknight dinner is a mash up of two of my great childhood loves: beef tacos and cheesy Hamburger ..." />
<meta name="twitter:title" content="Cheesy Beef Taco Skillet - Andie Mitchell" />
<meta name="twitter:site" content="@andiemmitchell" />
<meta name="twitter:image" content="https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-1.jpg" />
<meta name="twitter:creator" content="@andiemmitchell" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/www.andiemitchell.com\/","name":"Andie Mitchell","alternateName":"andiemitchell","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.andiemitchell.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Person","url":"https:\/\/www.andiemitchell.com\/cheesy-beef-taco-skillet\/","sameAs":["https:\/\/www.facebook.com\/andiemmitchell\/","https:\/\/www.instagram.com\/andiemmitchell\/","https:\/\/plus.google.com\/u\/0\/+AndieMitchellShow","https:\/\/www.pinterest.com\/andiemitchell\/","https:\/\/twitter.com\/andiemmitchell"],"@id":"#person","name":"Andie Mitchell"}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Andie Mitchell &raquo; Feed" href="https://www.andiemitchell.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Andie Mitchell &raquo; Comments Feed" href="https://www.andiemitchell.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Andie Mitchell &raquo; Cheesy Beef Taco Skillet Comments Feed" href="https://www.andiemitchell.com/cheesy-beef-taco-skillet/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.andiemitchell.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.7"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='social-warfare-block-css-css'  href='https://www.andiemitchell.com/wp-content/plugins/social-warfare/assets/js/post-editor/dist/blocks.style.build.css?ver=5.2.7' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.andiemitchell.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.7' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='jpibfi-style-css'  href='https://www.andiemitchell.com/wp-content/plugins/jquery-pin-it-button-for-images/css/client.css?ver=3.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='social_warfare-css'  href='https://www.andiemitchell.com/wp-content/plugins/social-warfare/assets/css/style.min.css?ver=4.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='twentytwelve-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:400italic,700italic,400,700&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='twentytwelve-style-css'  href='https://www.andiemitchell.com/wp-content/themes/Magnolia-AM/style.css?ver=5.2.7' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentytwelve-ie-css'  href='https://www.andiemitchell.com/wp-content/themes/twentytwelve/css/ie.css?ver=20121010' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.andiemitchell.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.3' type='text/css' media='all' />
<script type='text/javascript' src='https://www.andiemitchell.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.andiemitchell.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga'></script>
<link rel='https://api.w.org/' href='https://www.andiemitchell.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.andiemitchell.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.andiemitchell.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.7" />
<link rel='shortlink' href='https://wp.me/p7PIO2-4Kv' />
<link rel="alternate" type="application/json+oembed" href="https://www.andiemitchell.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.andiemitchell.com%2Fcheesy-beef-taco-skillet%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.andiemitchell.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.andiemitchell.com%2Fcheesy-beef-taco-skillet%2F&#038;format=xml" />
<style type="text/css">
	a.pinit-button.custom span {
		}

	.pinit-hover {
		opacity: 0.85 !important;
		filter: alpha(opacity=85) !important;
	}
	a.pinit-button {
	border-bottom: 0 !important;
	box-shadow: none !important;
	margin-bottom: 0 !important;
}
a.pinit-button::after {
    display: none;
}</style>
		<script type='text/javascript' async defer src='//assets.pinterest.com/js/pinit.js' data-pin-hover='true'></script>
<style type="text/css"> .wprm-comment-rating svg path, .comment-form-wprm-rating svg path { fill: #343434; } .comment-form-wprm-rating .wprm-rating-star.rated svg polygon { fill: #343434; } .wprm-comment-rating svg polygon, .comment-form-wprm-rating svg polygon { stroke: #343434; }</style><script type="text/javascript" async="" src="https://www.andiemitchell.com/wp-content/plugins/ziplist-recipe-plugin/zlrecipe_print.js"></script>
<link charset="utf-8" href="https://www.andiemitchell.com/wp-content/plugins/ziplist-recipe-plugin/zlrecipe-std.css" rel="stylesheet" type="text/css" />
<style type="text/css">
.comment-form .tasty-recipes-ratings-buttons {
  unicode-bidi: bidi-override;
  direction: rtl;
  text-align: center; }
  .comment-form .tasty-recipes-ratings-buttons > span {
    display: inline-block;
    position: relative;
    width: 1.1em; }
    .comment-form .tasty-recipes-ratings-buttons > span i {
      font-style: normal; }
    .comment-form .tasty-recipes-ratings-buttons > span .unchecked {
      display: inline-block; }
    .comment-form .tasty-recipes-ratings-buttons > span .checked {
      display: none; }
  .comment-form .tasty-recipes-ratings-buttons > input:checked ~ span .unchecked {
    display: none; }
  .comment-form .tasty-recipes-ratings-buttons > input:checked ~ span .checked {
    display: inline-block; }
  .comment-form .tasty-recipes-ratings-buttons > input:checked ~ span:before .unchecked {
    display: inline-block; }
  .comment-form .tasty-recipes-ratings-buttons > input:checked ~ span:before .checked {
    display: none; }
  @media only screen and (min-width: 1024px) {
    .comment-form .tasty-recipes-ratings-buttons > *:hover .unchecked,
    .comment-form .tasty-recipes-ratings-buttons > *:hover ~ span .unchecked,
    .comment-form .tasty-recipes-ratings-buttons:not(:hover) > input:checked ~ span .unchecked {
      display: none; }
    .comment-form .tasty-recipes-ratings-buttons > *:hover .checked,
    .comment-form .tasty-recipes-ratings-buttons > *:hover ~ span .checked,
    .comment-form .tasty-recipes-ratings-buttons:not(:hover) > input:checked ~ span .checked {
      display: inline-block; }
    .comment-form .tasty-recipes-ratings-buttons > *:hover:before .unchecked,
    .comment-form .tasty-recipes-ratings-buttons > *:hover ~ span:before .unchecked,
    .comment-form .tasty-recipes-ratings-buttons:not(:hover) > input:checked ~ span:before .unchecked {
      display: inline-block; }
    .comment-form .tasty-recipes-ratings-buttons > *:hover:before .checked,
    .comment-form .tasty-recipes-ratings-buttons > *:hover ~ span:before .checked,
    .comment-form .tasty-recipes-ratings-buttons:not(:hover) > input:checked ~ span:before .checked {
      display: none; } }
  .comment-form .tasty-recipes-ratings-buttons > input {
    margin-left: -1.1em;
    margin-right: 0;
    top: 3px;
    width: 1.1em;
    height: 1.1em;
    position: relative;
    z-index: 2;
    opacity: 0; }

</style>
<link rel="Shortcut Icon" type="image/x-icon" href="https://www.andiemitchell.com/wp-content/themes/Magnolia-AM/images/favicon.png" />	<style type="text/css" id="twentytwelve-header-css">
			.site-title,
		.site-description {
			position: absolute;
			clip: rect(1px 1px 1px 1px); /* IE7 */
			clip: rect(1px, 1px, 1px, 1px);
		}
		</style>
	<link rel="icon" href="https://www.andiemitchell.com/wp-content/uploads/2016/08/favicon-300x300.png" sizes="32x32" />
<link rel="icon" href="https://www.andiemitchell.com/wp-content/uploads/2016/08/favicon-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.andiemitchell.com/wp-content/uploads/2016/08/favicon-300x300.png" />
<meta name="msapplication-TileImage" content="https://www.andiemitchell.com/wp-content/uploads/2016/08/favicon-300x300.png" />
</head>

<body class="post-template-default single single-post postid-18259 custom-font-enabled single-author">
<nav id="site-navigation" class="main-navigation" role="navigation">
    <div id="woc-menu">
        <button class="menu-toggle"><i class="fa fa-bars"></i></button>
        <div class="menu-main-menu-container"><ul id="menu-main-menu" class="nav-menu"><li id="menu-item-15345" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-15345"><a href="https://www.andiemitchell.com/about/">About</a>
<ul class="sub-menu">
	<li id="menu-item-15340" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15340"><a href="https://www.andiemitchell.com/about/">Andie</a></li>
	<li id="menu-item-15341" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15341"><a href="https://www.andiemitchell.com/contact-me/">Contact</a></li>
	<li id="menu-item-15343" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15343"><a href="https://www.andiemitchell.com/privacy-policy/">Privacy Policy</a></li>
</ul>
</li>
<li id="menu-item-15346" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-15346"><a href="https://www.andiemitchell.com/category/recipes/">Recipes</a>
<ul class="sub-menu">
	<li id="menu-item-15347" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-15347"><a href="https://www.andiemitchell.com/category/recipes/">All Recipes</a></li>
	<li id="menu-item-15348" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15348"><a href="https://www.andiemitchell.com/category/recipes/appetizers/">Appetizers</a></li>
	<li id="menu-item-15349" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15349"><a href="https://www.andiemitchell.com/category/recipes/beef/">Beef</a></li>
	<li id="menu-item-15350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15350"><a href="https://www.andiemitchell.com/category/recipes/breakfast/">Breakfast</a></li>
	<li id="menu-item-15351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15351"><a href="https://www.andiemitchell.com/category/recipes/burgers/">Burgers and Sandwiches</a></li>
	<li id="menu-item-15352" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15352"><a href="https://www.andiemitchell.com/category/recipes/dessert/">Dessert</a></li>
	<li id="menu-item-15353" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15353"><a href="https://www.andiemitchell.com/category/recipes/low-carb/">Low Carb</a></li>
	<li id="menu-item-15354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15354"><a href="https://www.andiemitchell.com/category/recipes/pasta/">Pasta and Pizza</a></li>
	<li id="menu-item-15355" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15355"><a href="https://www.andiemitchell.com/category/recipes/pork/">Pork</a></li>
	<li id="menu-item-15356" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15356"><a href="https://www.andiemitchell.com/category/recipes/poultry/">Poultry</a></li>
	<li id="menu-item-15357" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15357"><a href="https://www.andiemitchell.com/category/recipes/salads/">Salads</a></li>
	<li id="menu-item-15358" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15358"><a href="https://www.andiemitchell.com/category/recipes/sauces/">Sauces</a></li>
	<li id="menu-item-15359" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15359"><a href="https://www.andiemitchell.com/category/recipes/seafood/">Seafood</a></li>
	<li id="menu-item-15360" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15360"><a href="https://www.andiemitchell.com/category/recipes/sides/">Sides</a></li>
	<li id="menu-item-15361" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15361"><a href="https://www.andiemitchell.com/category/recipes/slow-cooker/">Slow Cooker</a></li>
	<li id="menu-item-15362" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15362"><a href="https://www.andiemitchell.com/category/recipes/vegetarian/">Vegetarian</a></li>
</ul>
</li>
<li id="menu-item-15363" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-15363"><a href="https://www.andiemitchell.com/weight-loss/">Weight Loss</a>
<ul class="sub-menu">
	<li id="menu-item-15364" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15364"><a href="https://www.andiemitchell.com/weight-loss/my-135-pound-weight-loss-story/">My 135 Pound Weight Loss Story</a></li>
</ul>
</li>
<li id="menu-item-15365" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15365"><a href="https://www.andiemitchell.com/my-books/">Books</a></li>
<li id="menu-item-15366" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15366"><a href="https://www.andiemitchell.com/favorite">Shop</a></li>
<li class="search-link"><i class="fa fa-search"></i> <a href="#">Search</a>
			<div class="searchbar"><form name="search" action="/" method="get">
			<input type="text" name="s" value="Looking For Something?" autocomplete="off" onfocus="if (this.value == 'Looking For Something?') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Looking For Something?';}">
		</form>
		</div>
					</li></ul></div></div>
    <div class="menu-social-links-container"><ul id="menu-social-links" class="social-menu"><li id="menu-item-15330" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15330"><a target="_blank" rel="noopener noreferrer" href="https://www.bloglovin.com/blogs/andie-mitchell-14543037"><span>Bloglovin</span></a></li>
<li id="menu-item-15331" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15331"><a target="_blank" rel="noopener noreferrer" href="https://www.instagram.com/andiemmitchell/"><span>Instagram</span></a></li>
<li id="menu-item-15332" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15332"><a target="_blank" rel="noopener noreferrer" href="https://www.facebook.com/andiemmitchell/"><span>Facebook</span></a></li>
<li id="menu-item-15333" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15333"><a target="_blank" rel="noopener noreferrer" href="http://pinterest.com/andiemitchell/"><span>Pinterest</span></a></li>
<li id="menu-item-15334" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15334"><a target="_blank" rel="noopener noreferrer" href="https://twitter.com/andiemmitchell"><span>Twitter</span></a></li>
<li id="menu-item-15335" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15335"><a target="_blank" rel="noopener noreferrer" href="https://plus.google.com/u/0/+AndieMitchellShow"><span>Google+</span></a></li>
<li id="menu-item-15336" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15336"><a target="_blank" rel="noopener noreferrer" href="http://eepurl.com/bFmFif"><span>Mailchimp</span></a></li>
<li id="menu-item-15337" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15337"><a target="_blank" rel="noopener noreferrer" href="http://feedly.com/i/subscription/feed/https://www.andiemitchell.com/feed/"><span>RSS</span></a></li>
</ul></div>
    <div style="clear:both"></div>
</nav>
<!-- #site-navigation -->
<div id="page" class="hfeed site">
    <header id="masthead" class="site-header" role="banner">
                    <a href="https://www.andiemitchell.com/"><img src="https://www.andiemitchell.com/wp-content/uploads/2016/08/header.png"
                                                                 class="header-image"
                                                                 width="3000"
                                                                 height="600"
                                                                 alt=""/></a>
        
        <hgroup>
            <h1 class="site-title"><a href="https://www.andiemitchell.com/"
                                      title="Andie Mitchell"
                                      rel="home">Andie Mitchell</a></h1>

        </hgroup>

    </header>
        <div id="main" class="wrapper">
	<div id="primary" class="site-content">
		<div id="content" role="main">

			
				
<article id="post-18259" class="post-18259 post type-post status-publish has-post-thumbnail hentry category-beef category-low-carb tag-mexican tag-one-pan tag-quick-and-easy tag-tacos">
    <div class="postdate"><a href="https://www.andiemitchell.com/category/recipes/beef/" rel="category tag">Beef</a>&#183; <a href="https://www.andiemitchell.com/category/recipes/low-carb/" rel="category tag">Low Carb</a></div>
    <header class="entry-header">
                    <h1 class="entry-title">Cheesy Beef Taco Skillet</h1>
            </header>
    <div class="entry-content">
        <div class="wprm-recipe wprm-recipe-snippet wprm-recipe-template-snippet-basic-buttons"><a href="#wprm-recipe-container-18263" style="color: #ffffff;background-color: #000000;border-color: #333333;border-radius: 3px;padding: 5px 8px;" class="wprm-recipe-jump wprm-recipe-link wprm-jump-to-recipe-shortcode wprm-block-text-normal wprm-recipe-jump-inline-button wprm-recipe-link-inline-button wprm-color-accent"><span class="wprm-recipe-icon wprm-recipe-jump-icon"><svg xmlns="http://www.w3.org/2000/svg" width="16" height="16" viewBox="0 0 24 24"><g class="nc-icon-wrapper" fill="#ffffff"><path data-color="color-2" d="M9,2h6c0.6,0,1-0.4,1-1s-0.4-1-1-1H9C8.4,0,8,0.4,8,1S8.4,2,9,2z"></path> <path fill="#ffffff" d="M16,11V5c0-0.6-0.4-1-1-1H9C8.4,4,8,4.4,8,5v6H1.9L12,23.6L22.1,11H16z"></path></g></svg></span> Jump to Recipe</a>

<a href="https://www.andiemitchell.com/wprm_print/18263" style="color: #ffffff;background-color: #000000;border-color: #333333;border-radius: 3px;padding: 5px 8px;" class="wprm-recipe-print wprm-recipe-link wprm-print-recipe-shortcode wprm-block-text-normal wprm-recipe-print-inline-button wprm-recipe-link-inline-button wprm-color-accent" data-recipe-id="18263" target="_blank" rel="nofollow"><span class="wprm-recipe-icon wprm-recipe-print-icon"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g ><path fill="#ffffff" d="M19,5.09V1c0-0.552-0.448-1-1-1H6C5.448,0,5,0.448,5,1v4.09C2.167,5.569,0,8.033,0,11v7c0,0.552,0.448,1,1,1h4v4c0,0.552,0.448,1,1,1h12c0.552,0,1-0.448,1-1v-4h4c0.552,0,1-0.448,1-1v-7C24,8.033,21.833,5.569,19,5.09z M7,2h10v3H7V2z M17,22H7v-9h10V22z M18,10c-0.552,0-1-0.448-1-1c0-0.552,0.448-1,1-1s1,0.448,1,1C19,9.552,18.552,10,18,10z"/></g></svg></span> Print Recipe</a></div><div class="swp_social_panel swp_horizontal_panel swp_flat_fresh  swp_default_full_color swp_individual_full_color swp_other_full_color scale-100  scale-" data-min-width="1100" data-float-color="#ffffff" data-float="left" data-float-mobile="none" data-transition="slide" data-post-id="18259" ><div class="nc_tweetContainer swp_share_button swp_pinterest" data-network="pinterest"><a rel="nofollow noreferrer noopener" class="nc_tweet swp_share_link noPop" onClick="var e=document.createElement('script');
						e.setAttribute('type','text/javascript');
						e.setAttribute('charset','UTF-8');
						e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);
						document.body.appendChild(e);
					" ><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_pinterest_icon"></i><span class="swp_share">Pin</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_facebook" data-network="facebook"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.andiemitchell.com%2Fcheesy-beef-taco-skillet%2F" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.andiemitchell.com%2Fcheesy-beef-taco-skillet%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_twitter" data-network="twitter"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=Cheesy+Beef+Taco+Skillet&url=https%3A%2F%2Fwww.andiemitchell.com%2Fcheesy-beef-taco-skillet%2F&via=andiemmitchell" data-link="https://twitter.com/intent/tweet?text=Cheesy+Beef+Taco+Skillet&url=https%3A%2F%2Fwww.andiemitchell.com%2Fcheesy-beef-taco-skillet%2F&via=andiemmitchell"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div></div><input class="jpibfi" type="hidden">
<figure class="wp-block-image"><img data-pin-title="Cheesy Beef Taco Skillet " data-pin-description="This easy weeknight dinner recipe is a mash up of two of my great childhood loves: beef tacos and cheesy Hamburger Helper. It’s full of rich chili and cumin-spiced Mexican flavor with a deliciously creamy factor. And to make it that much better, it’s made all in one skillet in 30 minutes." src="https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-1.jpg" alt="" class="wp-image-18260" srcset="https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-1.jpg 1360w, https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-1-300x450.jpg 300w, https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-1-680x1020.jpg 680w, https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-1-624x936.jpg 624w" sizes="(max-width: 1360px) 100vw, 1360px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.andiemitchell.com/cheesy-beef-taco-skillet/" data-jpibfi-post-title="Cheesy Beef Taco Skillet" data-jpibfi-src="https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-1.jpg" ></figure>



<p>This easy weeknight dinner is a mash up of two of my great childhood loves: beef tacos and cheesy Hamburger Helper. It’s full of rich chili and cumin-spiced Mexican flavor with a deliciously creamy factor. And to make it that much better, it’s made all in one skillet in 30 minutes. You can serve it with egg noodles, a la Hamburger Helper, serve it over rice, on top of salad, or set up a toppings bar with all your favorite taco fixins! It’s a total crowd pleaser no matter what you do.</p>



<figure class="wp-block-image"><img data-pin-title="Cheesy Beef Taco Skillet " data-pin-description="This easy weeknight dinner recipe is a mash up of two of my great childhood loves: beef tacos and cheesy Hamburger Helper. It’s full of rich chili and cumin-spiced Mexican flavor with a deliciously creamy factor. And to make it that much better, it’s made all in one skillet in 30 minutes." src="https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-3.jpg" alt="" class="wp-image-18262" srcset="https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-3.jpg 1360w, https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-3-300x450.jpg 300w, https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-3-680x1020.jpg 680w, https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-3-624x936.jpg 624w" sizes="(max-width: 1360px) 100vw, 1360px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.andiemitchell.com/cheesy-beef-taco-skillet/" data-jpibfi-post-title="Cheesy Beef Taco Skillet" data-jpibfi-src="https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-3.jpg" ></figure>



<h2>How to Make It:</h2>



<p>First, make a homemade taco seasoning blend with:<br>
chili powder<br>
smoked paprika<br>
ground cumin<br>
ground coriander<br>
dried oregano<br>
cayenne pepper<br>
salt </p>



<p>Next, saute onion and pepper in a large skillet until soft. Transfer the cooked veggies to a bowl, then brown a pound of ground beef in the skillet. Add a few cloves of minced garlic and stir until fragrant. Add the spice mixture, let cook for about a minute. Return the veggies to the skillet then stir in chicken broth, canned tomato sauce, and a tablespoon of Worcestershire sauce. Bring the mixture to a simmer and let cook until thickened. Stir in cream cheese and cheddar cheese until smooth and melted. Voila! </p>



<figure class="wp-block-image"><img data-pin-title="Cheesy Beef Taco Skillet " data-pin-description="This easy weeknight dinner recipe is a mash up of two of my great childhood loves: beef tacos and cheesy Hamburger Helper. It’s full of rich chili and cumin-spiced Mexican flavor with a deliciously creamy factor. And to make it that much better, it’s made all in one skillet in 30 minutes." src="https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-2.jpg" alt="" class="wp-image-18261" srcset="https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-2.jpg 1360w, https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-2-300x450.jpg 300w, https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-2-680x1020.jpg 680w, https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-2-624x936.jpg 624w" sizes="(max-width: 1360px) 100vw, 1360px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.andiemitchell.com/cheesy-beef-taco-skillet/" data-jpibfi-post-title="Cheesy Beef Taco Skillet" data-jpibfi-src="https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-2.jpg" ></figure>


<div id="wprm-recipe-container-18263" class="wprm-recipe-container" data-recipe-id="18263"><div class="wprm-recipe wprm-recipe-template-compact"><div class="wprm-container-float-right">
	<div class="wprm-recipe-image wprm-block-image-normal"><img style="border-width: 0px;border-style: solid;border-color: #666666;" width="150" height="150" src="https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-1-500x500.jpg" class="attachment-150x150 size-150x150" alt="" data-pin-description="This easy weeknight dinner recipe is a mash up of two of my great childhood loves: beef tacos and cheesy Hamburger Helper. It’s full of rich chili and cumin-spiced Mexican flavor with a deliciously creamy factor. And to make it that much better, it’s made all in one skillet in 30 minutes." data-pin-title="Cheesy Beef Taco Skillet" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.andiemitchell.com/cheesy-beef-taco-skillet/" data-jpibfi-post-title="Cheesy Beef Taco Skillet" data-jpibfi-src="https://www.andiemitchell.com/wp-content/uploads/2020/05/cheesy_beef_taco_skillet-1-500x500.jpg" ></div>
	<div class="wprm-spacer" style="height: 5px"></div>
	<a href="https://www.andiemitchell.com/wprm_print/18263" style="color: #444444;background-color: #ffffff;border-color: #777777;border-radius: 0px;padding: 5px 5px;" class="wprm-recipe-print wprm-recipe-link wprm-print-recipe-shortcode wprm-block-text-normal wprm-recipe-print-wide-button wprm-recipe-link-wide-button wprm-color-accent" data-recipe-id="18263" target="_blank" rel="nofollow"><span class="wprm-recipe-icon wprm-recipe-print-icon"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g ><path fill="#444444" d="M19,5.09V1c0-0.552-0.448-1-1-1H6C5.448,0,5,0.448,5,1v4.09C2.167,5.569,0,8.033,0,11v7c0,0.552,0.448,1,1,1h4v4c0,0.552,0.448,1,1,1h12c0.552,0,1-0.448,1-1v-4h4c0.552,0,1-0.448,1-1v-7C24,8.033,21.833,5.569,19,5.09z M7,2h10v3H7V2z M17,22H7v-9h10V22z M18,10c-0.552,0-1-0.448-1-1c0-0.552,0.448-1,1-1s1,0.448,1,1C19,9.552,18.552,10,18,10z"/></g></svg></span> Print Recipe</a>
	
	<style>.wprm-recipe-rating .wprm-rating-star.wprm-rating-star-full svg * { fill: #343434; }</style><div class="wprm-recipe-rating"><span class="wprm-rating-star wprm-rating-star-1 wprm-rating-star-full" data-rating="1" data-color="#343434"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g  transform="translate(0, 0)"><polygon fill="none" stroke="#343434" stroke-width="2" stroke-linecap="square" stroke-miterlimit="10" points="12,2.6 15,9 21.4,9 16.7,13.9 18.6,21.4 12,17.6 5.4,21.4 7.3,13.9 2.6,9 9,9 " stroke-linejoin="miter"/></g></svg></span><span class="wprm-rating-star wprm-rating-star-2 wprm-rating-star-full" data-rating="2" data-color="#343434"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g  transform="translate(0, 0)"><polygon fill="none" stroke="#343434" stroke-width="2" stroke-linecap="square" stroke-miterlimit="10" points="12,2.6 15,9 21.4,9 16.7,13.9 18.6,21.4 12,17.6 5.4,21.4 7.3,13.9 2.6,9 9,9 " stroke-linejoin="miter"/></g></svg></span><span class="wprm-rating-star wprm-rating-star-3 wprm-rating-star-full" data-rating="3" data-color="#343434"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g  transform="translate(0, 0)"><polygon fill="none" stroke="#343434" stroke-width="2" stroke-linecap="square" stroke-miterlimit="10" points="12,2.6 15,9 21.4,9 16.7,13.9 18.6,21.4 12,17.6 5.4,21.4 7.3,13.9 2.6,9 9,9 " stroke-linejoin="miter"/></g></svg></span><span class="wprm-rating-star wprm-rating-star-4 wprm-rating-star-full" data-rating="4" data-color="#343434"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g  transform="translate(0, 0)"><polygon fill="none" stroke="#343434" stroke-width="2" stroke-linecap="square" stroke-miterlimit="10" points="12,2.6 15,9 21.4,9 16.7,13.9 18.6,21.4 12,17.6 5.4,21.4 7.3,13.9 2.6,9 9,9 " stroke-linejoin="miter"/></g></svg></span><span class="wprm-rating-star wprm-rating-star-5 wprm-rating-star-full" data-rating="5" data-color="#343434"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g  transform="translate(0, 0)"><polygon fill="none" stroke="#343434" stroke-width="2" stroke-linecap="square" stroke-miterlimit="10" points="12,2.6 15,9 21.4,9 16.7,13.9 18.6,21.4 12,17.6 5.4,21.4 7.3,13.9 2.6,9 9,9 " stroke-linejoin="miter"/></g></svg></span><div class="wprm-recipe-rating-details wprm-block-text-normal"><span class="wprm-recipe-rating-average">5</span> from <span class="wprm-recipe-rating-count">3</span> votes</div></div>
</div>
<h2 class="wprm-recipe-name wprm-block-text-bold">Cheesy Beef Taco Skillet</h2>
<div class="wprm-spacer" style="height: 5px"></div>

<div class="wprm-spacer"></div>
<div class="wprm-recipe-times-container wprm-recipe-details-container wprm-recipe-details-container-table wprm-block-text-normal" style="border-width: 1px;border-style: solid;border-color: #777777;"><div class="wprm-recipe-time-container wprm-recipe-prep-time-container wprm-recipe-block-container wprm-recipe-block-container-table wprm-block-text-normal" style="border-width: 1px;border-style: solid;border-color: #777777;"><span class="wprm-recipe-details-label wprm-block-text-faded wprm-recipe-time-label wprm-recipe-prep-time-label">Prep Time</span><span class="wprm-recipe-time wprm-block-text-normal"><span class="wprm-recipe-details wprm-recipe-details-minutes wprm-recipe-prep_time wprm-recipe-prep_time-minutes">10</span> <span class="wprm-recipe-details-unit wprm-recipe-details-minutes wprm-recipe-prep_time-unit wprm-recipe-prep_timeunit-minutes">mins</span></span></div><div class="wprm-recipe-time-container wprm-recipe-cook-time-container wprm-recipe-block-container wprm-recipe-block-container-table wprm-block-text-normal" style="border-width: 1px;border-style: solid;border-color: #777777;"><span class="wprm-recipe-details-label wprm-block-text-faded wprm-recipe-time-label wprm-recipe-cook-time-label">Cook Time</span><span class="wprm-recipe-time wprm-block-text-normal"><span class="wprm-recipe-details wprm-recipe-details-minutes wprm-recipe-cook_time wprm-recipe-cook_time-minutes">25</span> <span class="wprm-recipe-details-unit wprm-recipe-details-minutes wprm-recipe-cook_time-unit wprm-recipe-cook_timeunit-minutes">mins</span></span></div><div class="wprm-recipe-time-container wprm-recipe-total-time-container wprm-recipe-block-container wprm-recipe-block-container-table wprm-block-text-normal" style="border-width: 1px;border-style: solid;border-color: #777777;"><span class="wprm-recipe-details-label wprm-block-text-faded wprm-recipe-time-label wprm-recipe-total-time-label">Total Time</span><span class="wprm-recipe-time wprm-block-text-normal"><span class="wprm-recipe-details wprm-recipe-details-minutes wprm-recipe-total_time wprm-recipe-total_time-minutes">35</span> <span class="wprm-recipe-details-unit wprm-recipe-details-minutes wprm-recipe-total_time-unit wprm-recipe-total_timeunit-minutes">mins</span></span></div></div>
<div class="wprm-spacer" style="height: 5px"></div>
<div class="wprm-recipe-tags-container wprm-recipe-details-container wprm-recipe-details-container-inline wprm-block-text-normal" style=""><div class="wprm-recipe-tag-container wprm-recipe-course-container wprm-recipe-block-container wprm-recipe-block-container-inline wprm-block-text-normal" style=""><span class="wprm-recipe-details-label wprm-block-text-faded wprm-recipe-tag-label wprm-recipe-course-label">Course: </span><span class="wprm-recipe-course wprm-block-text-normal">Beef</span></div><div class="wprm-recipe-tag-container wprm-recipe-cuisine-container wprm-recipe-block-container wprm-recipe-block-container-inline wprm-block-text-normal" style=""><span class="wprm-recipe-details-label wprm-block-text-faded wprm-recipe-tag-label wprm-recipe-cuisine-label">Cuisine: </span><span class="wprm-recipe-cuisine wprm-block-text-normal">Mexican</span></div><div class="wprm-recipe-tag-container wprm-recipe-keyword-container wprm-recipe-block-container wprm-recipe-block-container-inline wprm-block-text-normal" style=""><span class="wprm-recipe-details-label wprm-block-text-faded wprm-recipe-tag-label wprm-recipe-keyword-label">Keyword: </span><span class="wprm-recipe-keyword wprm-block-text-normal">beef taco recipe</span></div></div>
<div class="wprm-recipe-servings-container wprm-recipe-block-container wprm-recipe-block-container-inline wprm-block-text-normal"><span class="wprm-recipe-details-label wprm-block-text-faded wprm-recipe-servings-label">Servings: </span><span class="wprm-recipe-servings wprm-recipe-details wprm-recipe-servings-18263 wprm-recipe-servings-adjustable-tooltip wprm-block-text-normal" data-recipe="18263" aria-label="Adjust recipe servings">4</span></div>
<div class="wprm-recipe-nutrition-container wprm-recipe-calories-container wprm-recipe-block-container wprm-recipe-block-container-inline wprm-block-text-normal"><span class="wprm-recipe-details-label wprm-block-text-faded wprm-recipe-nutrition-label wprm-recipe-calories-label">Calories: </span><span class="wprm-recipe-details wprm-recipe-nutrition wprm-recipe-calories wprm-block-text-normal">382</span><span class="wprm-recipe-details-unit wprm-recipe-nutrition-unit wprm-recipe-calories-unit wprm-block-text-normal">kcal</span></div>
<div class="wprm-recipe-author-container wprm-recipe-block-container wprm-recipe-block-container-inline wprm-block-text-normal"><span class="wprm-recipe-details-label wprm-block-text-faded wprm-recipe-author-label">Author: </span><span class="wprm-recipe-details wprm-recipe-author wprm-block-text-normal"><a href="https://www.andiemitchell.com/about/" target="_self">Andie Mitchell</a></span></div>


<div class="wprm-recipe-ingredients-container wprm-block-text-normal"><h3 class="wprm-recipe-header wprm-recipe-ingredients-header wprm-block-text-bold">Ingredients</h3><div class="wprm-recipe-ingredient-group"><h4 class="wprm-recipe-group-name wprm-recipe-ingredient-group-name wprm-block-text-bold">Spice Mixture</h4><ul class="wprm-recipe-ingredients"><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">2</span> <span class="wprm-recipe-ingredient-unit">tbsp</span> <span class="wprm-recipe-ingredient-name">chili powder</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">1</span> <span class="wprm-recipe-ingredient-unit">tbsp</span> <span class="wprm-recipe-ingredient-name">smoked paprika (optional)</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">1</span> <span class="wprm-recipe-ingredient-unit">tsp</span> <span class="wprm-recipe-ingredient-name">ground cumin</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">1</span> <span class="wprm-recipe-ingredient-unit">tsp</span> <span class="wprm-recipe-ingredient-name">ground coriander</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">1</span> <span class="wprm-recipe-ingredient-unit">tsp</span> <span class="wprm-recipe-ingredient-name">dried oregano</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">¼</span> <span class="wprm-recipe-ingredient-unit">tsp</span> <span class="wprm-recipe-ingredient-name">cayenne pepper</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">½</span> <span class="wprm-recipe-ingredient-unit">tsp</span> <span class="wprm-recipe-ingredient-name">salt</span></li></ul></div><div class="wprm-recipe-ingredient-group"><h4 class="wprm-recipe-group-name wprm-recipe-ingredient-group-name wprm-block-text-bold">Beef Taco Skillet</h4><ul class="wprm-recipe-ingredients"><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">2</span> <span class="wprm-recipe-ingredient-unit">tsp</span> <span class="wprm-recipe-ingredient-name">olive oil</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">1</span> <span class="wprm-recipe-ingredient-name">onion, thinly sliced</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">1</span> <span class="wprm-recipe-ingredient-name">bell pepper (any color), thinly sliced</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">1</span> <span class="wprm-recipe-ingredient-unit">lb</span> <span class="wprm-recipe-ingredient-name">90% lean ground beef</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">3</span> <span class="wprm-recipe-ingredient-name">garlic cloves, minced</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">½</span> <span class="wprm-recipe-ingredient-unit">cup</span> <span class="wprm-recipe-ingredient-name">chicken broth</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">½</span> <span class="wprm-recipe-ingredient-unit">cup</span> <span class="wprm-recipe-ingredient-name">canned tomato sauce</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">1</span> <span class="wprm-recipe-ingredient-unit">tbsp</span> <span class="wprm-recipe-ingredient-name">Worcestershire sauce (or soy sauce)</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">2</span> <span class="wprm-recipe-ingredient-unit">oz</span> <span class="wprm-recipe-ingredient-name">cream cheese</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">2</span> <span class="wprm-recipe-ingredient-unit">oz</span> <span class="wprm-recipe-ingredient-name">cheddar cheese, grated (1/2 cup)</span></li></ul></div></div>
<div class="wprm-recipe-instructions-container wprm-block-text-normal"><h3 class="wprm-recipe-header wprm-recipe-instructions-header wprm-block-text-bold">Instructions</h3><div class="wprm-recipe-instruction-group"><ul class="wprm-recipe-instructions"><li id="wprm-recipe-18263-step-0-0" class="wprm-recipe-instruction" style="list-style-type: decimal;"><div class="wprm-recipe-instruction-text" style="margin-bottom: 5px"><span style="display: block;">In a small bowl, whisk together all spice ingredients. Set aside.</span></div> </li><li id="wprm-recipe-18263-step-0-1" class="wprm-recipe-instruction" style="list-style-type: decimal;"><div class="wprm-recipe-instruction-text" style="margin-bottom: 5px"><span style="display: block;">In a large skillet, heat the oil over medium heat until hot. Add the sliced onion and bell pepper and cook, stirring occasionally, until softened, about 6 minutes. Transfer to a bowl and return the skillet to heat. Add the ground beef and cook, breaking it up as it browns, until beef is no longer pink, about 5 minutes. Add the garlic and stir for 30 seconds. Add the spice mixture and stir to coat the beef crumbles, about 20 seconds. Return the cooked peppers and onions to the skillet and stir in the tomato sauce, chicken broth, and Worcestershire sauce; bring to a simmer. Reduce the heat to medium-low and simmer, uncovered, stirring frequently, until the sauce has thickened slightly, about 5 minutes. Stir in the cream cheese and cheddar cheese until smooth and melted. Serve with egg noodles or rice or your favorite taco fixings!</span></div> </li></ul></div></div>


<h3 class="wprm-recipe-header wprm-recipe-nutrition-header wprm-block-text-bold">Nutrition</h3><div class="wprm-nutrition-label-container wprm-nutrition-label-container-simple wprm-block-text-normal" style="text-align: left;"><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Calories: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">382</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">kcal</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Carbohydrates: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">12</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">g</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Protein: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">29</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">g</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Fat: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">24</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">g</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Saturated Fat: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">11</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">g</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Cholesterol: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">104</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">mg</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Sodium: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">879</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">mg</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Potassium: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">795</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">mg</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Fiber: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">4</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">g</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Sugar: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">5</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">g</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Vitamin A: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">3496</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">IU</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Vitamin C: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">45</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">mg</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Calcium: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">182</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">mg</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Iron: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">5</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">mg</span></span></div></div></div><div class="swp_social_panel swp_horizontal_panel swp_flat_fresh  swp_default_full_color swp_individual_full_color swp_other_full_color scale-100  scale-" data-min-width="1100" data-float-color="#ffffff" data-float="left" data-float-mobile="none" data-transition="slide" data-post-id="18259" ><div class="nc_tweetContainer swp_share_button swp_pinterest" data-network="pinterest"><a rel="nofollow noreferrer noopener" class="nc_tweet swp_share_link noPop" onClick="var e=document.createElement('script');
						e.setAttribute('type','text/javascript');
						e.setAttribute('charset','UTF-8');
						e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);
						document.body.appendChild(e);
					" ><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_pinterest_icon"></i><span class="swp_share">Pin</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_facebook" data-network="facebook"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.andiemitchell.com%2Fcheesy-beef-taco-skillet%2F" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.andiemitchell.com%2Fcheesy-beef-taco-skillet%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_twitter" data-network="twitter"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=Cheesy+Beef+Taco+Skillet&url=https%3A%2F%2Fwww.andiemitchell.com%2Fcheesy-beef-taco-skillet%2F&via=andiemmitchell" data-link="https://twitter.com/intent/tweet?text=Cheesy+Beef+Taco+Skillet&url=https%3A%2F%2Fwww.andiemitchell.com%2Fcheesy-beef-taco-skillet%2F&via=andiemmitchell"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div></div><div class="swp-content-locator"></div>            </div>
    <footer class="entry-meta">
        <div class="cl">
            <div class="footer-comments">
                                    <div class="comments-link">
                        <a href="https://www.andiemitchell.com/cheesy-beef-taco-skillet/#comments">4 Comments</a>                    </div>
                    <!-- .comments-link -->
                            </div>
        </div>
        <div class="cr">Share:
            <script>function fbs_click() {
                    u = location.href;
                    t = document.title;
                    window.open('http://www.facebook.com/sharer.php?u=' + encodeURIComponent(u) + '&t=' + encodeURIComponent(t), 'sharer', 'toolbar=0,status=0,width=626,height=436');
                    return false;
                }</script>
            <a href="http://www.facebook.com/share.php?u=https://www.andiemitchell.com/cheesy-beef-taco-skillet/&t=Cheesy Beef Taco Skillet"
               onclick="return fbs_click()" target="_blank" target="_blank"><i class="fa fa-facebook"></i></a>

            <a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.andiemitchell.com%2Fcheesy-beef-taco-skillet%2F&amp;text=Cheesy Beef Taco Skillet&amp;"
               target="_blank"><i class="fa fa-twitter"></i></a>
            <a href="javascript:void((function()%7Bvar%20e=document.createElement('script');e.setAttribute('type','text/javascript');e.setAttribute('charset','UTF-8');e.setAttribute('src','http://assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)%7D)());"><i
                    class="fa fa-pinterest"></i></a>
            <a href="https://plus.google.com/share?url=url=https%3A%2F%2Fwww.andiemitchell.com%2Fcheesy-beef-taco-skillet%2F&amp;text=Cheesy Beef Taco Skillet&amp;"
               target="_blank"><i class="fa fa-google-plus"></i></a>
            <a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.andiemitchell.com%2Fcheesy-beef-taco-skillet%2F"
               target="_blank"><i class="fa fa-stumbleupon"></i></a>
            <a href="mailto:?subject=Cheesy Beef Taco Skillet&amp;body=Check out this post https%3A%2F%2Fwww.andiemitchell.com%2Fcheesy-beef-taco-skillet%2F&amp;text=Cheesy Beef Taco Skillet&amp;"
               target="_blank"><i class="fa fa-envelope"></i></a>
        </div>
        <div style="clear:both;"></div>
    </footer>
</article><!-- #post -->
    <div class="relatedposts">
        <h4> You Might Also Like</h4>
        
                                
<article id="post-abbr"18282" class="post-18282 post type-post status-publish has-post-thumbnail hentry category-pasta category-seafood tag-broccoli tag-lemon tag-pasta tag-quick-and-easy tag-shrimp">
<div class="featured" style="background-image: url(https://www.andiemitchell.com/wp-content/uploads/2020/06/Farfalle_Pasta_with_Shrimp__Roasted_Broccoli__Lemon_and_Parmesan-1-2.jpg)">
    <a href="https://www.andiemitchell.com/farfalle-pasta-with-shrimp-roasted-broccoli-lemon-and-parmesan/" rel="bookmark">Farfalle Pasta with Shrimp, Roasted Broccoli, Lemon and Parmesan</a></div>

</article><!-- #post -->

            
                                
<article id="post-abbr"18105" class="post-18105 post type-post status-publish has-post-thumbnail hentry category-beef category-burgers category-low-carb category-recipes tag-30-minutes tag-cheeseburger tag-one-pan">
<div class="featured" style="background-image: url(https://www.andiemitchell.com/wp-content/uploads/2020/03/cheeseburger_skillet_mushroom_swiss_burger-4.jpg)">
    <a href="https://www.andiemitchell.com/lighter-cheeseburger-skillet-with-mushrooms-and-swiss/" rel="bookmark">Lighter Cheeseburger Skillet with Mushrooms and Swiss</a></div>

</article><!-- #post -->

            
                                
<article id="post-abbr"17636" class="post-17636 post type-post status-publish has-post-thumbnail hentry category-poultry category-recipes tag-artichokes tag-chicken tag-italian tag-mediterranean tag-quick-and-easy">
<div class="featured" style="background-image: url(https://www.andiemitchell.com/wp-content/uploads/2019/07/chicken_artichokes_sun_dried_tomatoes_feta_cheese-3.jpg)">
    <a href="https://www.andiemitchell.com/best-grilled-chicken-recipe-with-artichokes-sun-dried-tomatoes-and-feta/" rel="bookmark">Best Grilled Chicken Recipe with Artichokes, Sun Dried Tomatoes and Feta</a></div>

</article><!-- #post -->

                </div>
            <div class="postcta">
            <div class="widget"><h3 class="widget-title">Subscribe!</h3>			<div class="textwidget"><form action="//andiemitchell.us12.list-manage.com/subscribe/post?u=bc99a5d0504383d1d8f673a0c&amp;id=67504c4890" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
<div class="mc-field-group">
	<input type="email" size="40" value="ENTER YOUR EMAIL" name="EMAIL" class="required email" id="mce-EMAIL" onfocus="if(this.value==this.defaultValue)this.value='';" onblur="if(this.value=='')this.value=this.defaultValue;" >
</div>
<div class="mc-field-group">
	<input type="text" size="40" value="ENTER YOUR NAME" name="FNAME" class="" id="mce-FNAME" onfocus="if(this.value==this.defaultValue)this.value='';" onblur="if(this.value=='')this.value=this.defaultValue;" >
</div>
	<div id="mce-responses" class="clear">
		<div class="response" id="mce-error-response" style="display:none"></div>
		<div class="response" id="mce-success-response" style="display:none"></div>
	</div>    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;"><input type="text" name="b_bc99a5d0504383d1d8f673a0c_67504c4890" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form></div>
		</div>        </div>
    
				<nav class="nav-single">
					<h3 class="assistive-text">Post navigation</h3>
					<span class="nav-previous"><a href="https://www.andiemitchell.com/5-great-summer-salads/" rel="prev"><span class="meta-nav">&larr;</span> 5 Great Summer Salads</a></span>
					<span class="nav-next"><a href="https://www.andiemitchell.com/what-i-love-this-week-41/" rel="next">What I Love This Week <span class="meta-nav">&rarr;</span></a></span>
				</nav><!-- .nav-single -->

				
<div id="comments" class="comments-area">

	
			<h2 class="comments-title">
			4 thoughts on &ldquo;<span>Cheesy Beef Taco Skillet</span>&rdquo;		</h2>

		<ol class="commentlist">
				<li class="comment even thread-even depth-1" id="li-comment-1402874">
		<article id="comment-1402874" class="comment">
			<header class="comment-meta comment-author vcard">
				<img alt='' src='https://secure.gravatar.com/avatar/7480d20218ae0124b316da0e5c796221?s=44&#038;d=blank&#038;r=g' srcset='https://secure.gravatar.com/avatar/7480d20218ae0124b316da0e5c796221?s=88&#038;d=blank&#038;r=g 2x' class='avatar avatar-44 photo' height='44' width='44' /><cite><b class="fn">Taha</b> </cite><a href="https://www.andiemitchell.com/cheesy-beef-taco-skillet/#comment-1402874"><time datetime="2020-05-29T05:18:08-04:00">May 29, 2020 at 5:18 am</time></a>			</header><!-- .comment-meta -->

			
			<section class="comment-content comment">
				<p><img class="wprm-comment-rating" src="https://www.andiemitchell.com/wp-content/plugins/wp-recipe-maker/assets/icons/rating/stars-5.svg" alt="5 stars" width="80" height="16" /><br />
This is an awesome recipe</p>
							</section><!-- .comment-content -->

			<div class="reply">
				<a rel='nofollow' class='comment-reply-link' href='/cheesy-beef-taco-skillet/?replytocom=1402874#respond' data-commentid="1402874" data-postid="18259" data-belowelement="comment-1402874" data-respondelement="respond" aria-label='Reply to Taha'>Reply</a> <span>&darr;</span>			</div><!-- .reply -->
		</article><!-- #comment-## -->
	</li><!-- #comment-## -->
	<li class="comment odd alt thread-odd thread-alt depth-1" id="li-comment-1402889">
		<article id="comment-1402889" class="comment">
			<header class="comment-meta comment-author vcard">
				<img alt='' src='https://secure.gravatar.com/avatar/7521fb0563f7e2e3646478d6e68f3e75?s=44&#038;d=blank&#038;r=g' srcset='https://secure.gravatar.com/avatar/7521fb0563f7e2e3646478d6e68f3e75?s=88&#038;d=blank&#038;r=g 2x' class='avatar avatar-44 photo' height='44' width='44' /><cite><b class="fn">Erin T</b> </cite><a href="https://www.andiemitchell.com/cheesy-beef-taco-skillet/#comment-1402889"><time datetime="2020-05-29T17:23:23-04:00">May 29, 2020 at 5:23 pm</time></a>			</header><!-- .comment-meta -->

			
			<section class="comment-content comment">
				<p><img class="wprm-comment-rating" src="https://www.andiemitchell.com/wp-content/plugins/wp-recipe-maker/assets/icons/rating/stars-5.svg" alt="5 stars" width="80" height="16" /><br />
Another winner Andie! I know I will making this again and again. We are keeping things low carb over here so I mixed in cauliflower rice before serving and it was a so good. Thank you!!</p>
							</section><!-- .comment-content -->

			<div class="reply">
				<a rel='nofollow' class='comment-reply-link' href='/cheesy-beef-taco-skillet/?replytocom=1402889#respond' data-commentid="1402889" data-postid="18259" data-belowelement="comment-1402889" data-respondelement="respond" aria-label='Reply to Erin T'>Reply</a> <span>&darr;</span>			</div><!-- .reply -->
		</article><!-- #comment-## -->
	</li><!-- #comment-## -->
	<li class="comment even thread-even depth-1" id="li-comment-1403029">
		<article id="comment-1403029" class="comment">
			<header class="comment-meta comment-author vcard">
				<img alt='' src='https://secure.gravatar.com/avatar/d233869ee49dc8e2306d5ebf08cbc97d?s=44&#038;d=blank&#038;r=g' srcset='https://secure.gravatar.com/avatar/d233869ee49dc8e2306d5ebf08cbc97d?s=88&#038;d=blank&#038;r=g 2x' class='avatar avatar-44 photo' height='44' width='44' /><cite><b class="fn"><a href='https://wearejetson.com' rel='external nofollow' class='url'>Albertina Geller</a></b> </cite><a href="https://www.andiemitchell.com/cheesy-beef-taco-skillet/#comment-1403029"><time datetime="2020-06-05T08:27:06-04:00">June 5, 2020 at 8:27 am</time></a>			</header><!-- .comment-meta -->

			
			<section class="comment-content comment">
				<p><img class="wprm-comment-rating" src="https://www.andiemitchell.com/wp-content/plugins/wp-recipe-maker/assets/icons/rating/stars-5.svg" alt="5 stars" width="80" height="16" /><br />
I loved this recipe so much! I am not the biggest fan of Beef but my roommate loves it so I gave this a shot and I am so glad I did. Thank you for sharing this!!</p>
							</section><!-- .comment-content -->

			<div class="reply">
				<a rel='nofollow' class='comment-reply-link' href='/cheesy-beef-taco-skillet/?replytocom=1403029#respond' data-commentid="1403029" data-postid="18259" data-belowelement="comment-1403029" data-respondelement="respond" aria-label='Reply to Albertina Geller'>Reply</a> <span>&darr;</span>			</div><!-- .reply -->
		</article><!-- #comment-## -->
	</li><!-- #comment-## -->
	<li class="comment odd alt thread-odd thread-alt depth-1" id="li-comment-1403261">
		<article id="comment-1403261" class="comment">
			<header class="comment-meta comment-author vcard">
				<img alt='' src='https://secure.gravatar.com/avatar/a967624cc35d7f0fb85652b60005dce9?s=44&#038;d=blank&#038;r=g' srcset='https://secure.gravatar.com/avatar/a967624cc35d7f0fb85652b60005dce9?s=88&#038;d=blank&#038;r=g 2x' class='avatar avatar-44 photo' height='44' width='44' /><cite><b class="fn"><a href='http://Bit.ly/DietEliminateWeightFAster' rel='external nofollow' class='url'>Lucas</a></b> </cite><a href="https://www.andiemitchell.com/cheesy-beef-taco-skillet/#comment-1403261"><time datetime="2020-06-12T09:32:09-04:00">June 12, 2020 at 9:32 am</time></a>			</header><!-- .comment-meta -->

			
			<section class="comment-content comment">
				<p>Hi, that cheesy beef look amazing, very helpful recipe!</p>
							</section><!-- .comment-content -->

			<div class="reply">
				<a rel='nofollow' class='comment-reply-link' href='/cheesy-beef-taco-skillet/?replytocom=1403261#respond' data-commentid="1403261" data-postid="18259" data-belowelement="comment-1403261" data-respondelement="respond" aria-label='Reply to Lucas'>Reply</a> <span>&darr;</span>			</div><!-- .reply -->
		</article><!-- #comment-## -->
	</li><!-- #comment-## -->
		</ol><!-- .commentlist -->

		
		
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/cheesy-beef-taco-skillet/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.andiemitchell.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<span class="agree-comment-policy">You have to agree to the comment policy.</span><p class="comment-form-wprm-rating" data-color="#343434">
	<label for="wprm-rating">Recipe Rating</label>
	<span class="wprm-rating-stars">
		<span class="wprm-rating-star" data-rating="1"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g  transform="translate(0, 0)"><polygon fill="none" stroke="#343434" stroke-width="2" stroke-linecap="square" stroke-miterlimit="10" points="12,2.6 15,9 21.4,9 16.7,13.9 18.6,21.4 12,17.6 5.4,21.4 7.3,13.9 2.6,9 9,9 " stroke-linejoin="miter"/></g></svg></span><span class="wprm-rating-star" data-rating="2"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g  transform="translate(0, 0)"><polygon fill="none" stroke="#343434" stroke-width="2" stroke-linecap="square" stroke-miterlimit="10" points="12,2.6 15,9 21.4,9 16.7,13.9 18.6,21.4 12,17.6 5.4,21.4 7.3,13.9 2.6,9 9,9 " stroke-linejoin="miter"/></g></svg></span><span class="wprm-rating-star" data-rating="3"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g  transform="translate(0, 0)"><polygon fill="none" stroke="#343434" stroke-width="2" stroke-linecap="square" stroke-miterlimit="10" points="12,2.6 15,9 21.4,9 16.7,13.9 18.6,21.4 12,17.6 5.4,21.4 7.3,13.9 2.6,9 9,9 " stroke-linejoin="miter"/></g></svg></span><span class="wprm-rating-star" data-rating="4"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g  transform="translate(0, 0)"><polygon fill="none" stroke="#343434" stroke-width="2" stroke-linecap="square" stroke-miterlimit="10" points="12,2.6 15,9 21.4,9 16.7,13.9 18.6,21.4 12,17.6 5.4,21.4 7.3,13.9 2.6,9 9,9 " stroke-linejoin="miter"/></g></svg></span><span class="wprm-rating-star" data-rating="5"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g  transform="translate(0, 0)"><polygon fill="none" stroke="#343434" stroke-width="2" stroke-linecap="square" stroke-miterlimit="10" points="12,2.6 15,9 21.4,9 16.7,13.9 18.6,21.4 12,17.6 5.4,21.4 7.3,13.9 2.6,9 9,9 " stroke-linejoin="miter"/></g></svg></span>	</span>
	<input id="wprm-comment-rating" name="wprm-comment-rating" type="hidden" value="0">
</p>
<p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='18259' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="3920d95b44" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="197"/></p>			</form>
			</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div><!-- #comments .comments-area -->
			
		</div><!-- #content -->
	</div><!-- #primary -->


			<div id="secondary" class="widget-area" role="complementary">
			<aside id="text-25" class="widget widget_text"><h3 class="widget-title">Meet Andie</h3>			<div class="textwidget"><a href="https://www.andiemitchell.com/about/"><img src="https://www.andiemitchell.com/wp-content/uploads/2016/08/sidebar.jpg" alt="Andie Mitchell"></a></div>
		</aside><aside id="text-30" class="widget widget_text"><h3 class="widget-title">Never Miss A Post!</h3>			<div class="textwidget"><form action="//andiemitchell.us12.list-manage.com/subscribe/post?u=bc99a5d0504383d1d8f673a0c&amp;id=67504c4890" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
<div class="mc-field-group">
	<input type="email" size="40" value="ENTER YOUR EMAIL" name="EMAIL" class="required email" id="mce-EMAIL" onfocus="if(this.value==this.defaultValue)this.value='';" onblur="if(this.value=='')this.value=this.defaultValue;" >
</div>
<div class="mc-field-group">
	<input type="text" size="40" value="ENTER YOUR NAME" name="FNAME" class="" id="mce-FNAME" onfocus="if(this.value==this.defaultValue)this.value='';" onblur="if(this.value=='')this.value=this.defaultValue;" >
</div>
	<div id="mce-responses" class="clear">
		<div class="response" id="mce-error-response" style="display:none"></div>
		<div class="response" id="mce-success-response" style="display:none"></div>
	</div>    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;"><input type="text" name="b_bc99a5d0504383d1d8f673a0c_67504c4890" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form></div>
		</aside><aside id="text-32" class="widget widget_text"><h3 class="widget-title">Check Out My Books!</h3>			<div class="textwidget"><center><a href="https://www.andiemitchell.com/my-books/" rel="nofollow"><img src="https://www.andiemitchell.com/wp-content/uploads/2016/05/Andie-Mitchell-Books.png"</a></center></div>
		</aside><aside id="top-posts-2" class="widget widget_top-posts"><h3 class="widget-title">Reader Favorites</h3><div class='widgets-grid-layout no-grav'>
					<div class="widget-grid-view-image">
						<a href="https://www.andiemitchell.com/farfalle-pasta-with-shrimp-roasted-broccoli-lemon-and-parmesan/" title="Farfalle Pasta with Shrimp, Roasted Broccoli, Lemon and Parmesan" class="bump-view" data-bump-view="tp"><img width="200" height="200" src="https://i0.wp.com/www.andiemitchell.com/wp-content/uploads/2020/06/Farfalle_Pasta_with_Shrimp__Roasted_Broccoli__Lemon_and_Parmesan-1-2.jpg?resize=200%2C200&#038;ssl=1" alt="Farfalle Pasta with Shrimp, Roasted Broccoli, Lemon and Parmesan" data-pin-nopin="true"/></a>						</div>
										<div class="widget-grid-view-image">
						<a href="https://www.andiemitchell.com/what-i-love-this-week-43/" title="What I Love This Week" class="bump-view" data-bump-view="tp"><img width="200" height="200" src="https://i2.wp.com/www.andiemitchell.com/wp-content/uploads/2018/11/popcorn-2.jpg?resize=200%2C200&#038;ssl=1" alt="What I Love This Week" data-pin-nopin="true"/></a>						</div>
										<div class="widget-grid-view-image">
						<a href="https://www.andiemitchell.com/perfect-mashed-sweet-potatoes/" title="Perfect Mashed Sweet Potatoes" class="bump-view" data-bump-view="tp"><img width="200" height="200" src="https://i0.wp.com/www.andiemitchell.com/wp-content/uploads/2013/04/perfect_mashed_sweet_potatoes_recipe-1.jpg?resize=200%2C200&#038;ssl=1" alt="Perfect Mashed Sweet Potatoes" data-pin-nopin="true"/></a>						</div>
										<div class="widget-grid-view-image">
						<a href="https://www.andiemitchell.com/honey-barbecue-meatloaf/" title="Honey Barbecue Meatloaf Recipe" class="bump-view" data-bump-view="tp"><img width="200" height="200" src="https://i2.wp.com/www.andiemitchell.com/wp-content/uploads/2011/03/honey_barbecue_meatloaf_recipe-1-1.jpg?resize=200%2C200&#038;ssl=1" alt="Honey Barbecue Meatloaf Recipe" data-pin-nopin="true"/></a>						</div>
										<div class="widget-grid-view-image">
						<a href="https://www.andiemitchell.com/crispy-buffalo-chicken/" title="Crispy Buffalo Chicken Tenders" class="bump-view" data-bump-view="tp"><img width="200" height="200" src="https://i2.wp.com/www.andiemitchell.com/wp-content/uploads/2010/11/buffalo-chicken-fingers.jpg?resize=200%2C200&#038;ssl=1" alt="Crispy Buffalo Chicken Tenders" data-pin-nopin="true"/></a>						</div>
										<div class="widget-grid-view-image">
						<a href="https://www.andiemitchell.com/white-bean-puttanesca-with-garlic-bread/" title="White Bean Puttanesca with Garlic Bread" class="bump-view" data-bump-view="tp"><img width="200" height="200" src="https://i0.wp.com/www.andiemitchell.com/wp-content/uploads/2014/04/puttanesca.jpg?resize=200%2C200&#038;ssl=1" alt="White Bean Puttanesca with Garlic Bread" data-pin-nopin="true"/></a>						</div>
										<div class="widget-grid-view-image">
						<a href="https://www.andiemitchell.com/greek-lamb-meatballs/" title="Greek Lamb Meatballs" class="bump-view" data-bump-view="tp"><img width="200" height="200" src="https://i2.wp.com/www.andiemitchell.com/wp-content/uploads/2019/11/greek_lamb_meatballs_recipe-7.jpg?resize=200%2C200&#038;ssl=1" alt="Greek Lamb Meatballs" data-pin-nopin="true"/></a>						</div>
										<div class="widget-grid-view-image">
						<a href="https://www.andiemitchell.com/in-n-out-burger-recipe-with-lighter-secret-spread/" title="Homemade In-N-Out Burger Recipe with Lighter Secret Spread" class="bump-view" data-bump-view="tp"><img width="200" height="200" src="https://i2.wp.com/www.andiemitchell.com/wp-content/uploads/2016/07/homemade_lighter_in_n_out_burger_recipe_with_secret_sauce-1-3.jpg?resize=200%2C200&#038;ssl=1" alt="Homemade In-N-Out Burger Recipe with Lighter Secret Spread" data-pin-nopin="true"/></a>						</div>
										<div class="widget-grid-view-image">
						<a href="https://www.andiemitchell.com/fool-proof-turkey-meatloaf/" title="Fool Proof Turkey Meatloaf" class="bump-view" data-bump-view="tp"><img width="200" height="200" src="https://i0.wp.com/www.andiemitchell.com/wp-content/uploads/2013/04/foolproof_turkey_meatloaf-3.jpg?resize=200%2C200&#038;ssl=1" alt="Fool Proof Turkey Meatloaf" data-pin-nopin="true"/></a>						</div>
					</div>
</aside><aside id="archives-5" class="widget widget_archive"><h3 class="widget-title">Archives</h3>		<label class="screen-reader-text" for="archives-dropdown-5">Archives</label>
		<select id="archives-dropdown-5" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://www.andiemitchell.com/2020/06/'> June 2020 </option>
	<option value='https://www.andiemitchell.com/2020/05/'> May 2020 </option>
	<option value='https://www.andiemitchell.com/2020/04/'> April 2020 </option>
	<option value='https://www.andiemitchell.com/2020/03/'> March 2020 </option>
	<option value='https://www.andiemitchell.com/2020/02/'> February 2020 </option>
	<option value='https://www.andiemitchell.com/2020/01/'> January 2020 </option>
	<option value='https://www.andiemitchell.com/2019/12/'> December 2019 </option>
	<option value='https://www.andiemitchell.com/2019/11/'> November 2019 </option>
	<option value='https://www.andiemitchell.com/2019/10/'> October 2019 </option>
	<option value='https://www.andiemitchell.com/2019/09/'> September 2019 </option>
	<option value='https://www.andiemitchell.com/2019/08/'> August 2019 </option>
	<option value='https://www.andiemitchell.com/2019/07/'> July 2019 </option>
	<option value='https://www.andiemitchell.com/2019/06/'> June 2019 </option>
	<option value='https://www.andiemitchell.com/2019/05/'> May 2019 </option>
	<option value='https://www.andiemitchell.com/2019/04/'> April 2019 </option>
	<option value='https://www.andiemitchell.com/2019/03/'> March 2019 </option>
	<option value='https://www.andiemitchell.com/2019/02/'> February 2019 </option>
	<option value='https://www.andiemitchell.com/2019/01/'> January 2019 </option>
	<option value='https://www.andiemitchell.com/2018/12/'> December 2018 </option>
	<option value='https://www.andiemitchell.com/2018/11/'> November 2018 </option>
	<option value='https://www.andiemitchell.com/2018/10/'> October 2018 </option>
	<option value='https://www.andiemitchell.com/2018/09/'> September 2018 </option>
	<option value='https://www.andiemitchell.com/2018/08/'> August 2018 </option>
	<option value='https://www.andiemitchell.com/2018/07/'> July 2018 </option>
	<option value='https://www.andiemitchell.com/2018/06/'> June 2018 </option>
	<option value='https://www.andiemitchell.com/2018/05/'> May 2018 </option>
	<option value='https://www.andiemitchell.com/2018/04/'> April 2018 </option>
	<option value='https://www.andiemitchell.com/2018/03/'> March 2018 </option>
	<option value='https://www.andiemitchell.com/2018/02/'> February 2018 </option>
	<option value='https://www.andiemitchell.com/2018/01/'> January 2018 </option>
	<option value='https://www.andiemitchell.com/2017/12/'> December 2017 </option>
	<option value='https://www.andiemitchell.com/2017/11/'> November 2017 </option>
	<option value='https://www.andiemitchell.com/2017/10/'> October 2017 </option>
	<option value='https://www.andiemitchell.com/2017/09/'> September 2017 </option>
	<option value='https://www.andiemitchell.com/2017/08/'> August 2017 </option>
	<option value='https://www.andiemitchell.com/2017/07/'> July 2017 </option>
	<option value='https://www.andiemitchell.com/2017/06/'> June 2017 </option>
	<option value='https://www.andiemitchell.com/2017/05/'> May 2017 </option>
	<option value='https://www.andiemitchell.com/2017/04/'> April 2017 </option>
	<option value='https://www.andiemitchell.com/2017/03/'> March 2017 </option>
	<option value='https://www.andiemitchell.com/2017/02/'> February 2017 </option>
	<option value='https://www.andiemitchell.com/2017/01/'> January 2017 </option>
	<option value='https://www.andiemitchell.com/2016/12/'> December 2016 </option>
	<option value='https://www.andiemitchell.com/2016/11/'> November 2016 </option>
	<option value='https://www.andiemitchell.com/2016/10/'> October 2016 </option>
	<option value='https://www.andiemitchell.com/2016/09/'> September 2016 </option>
	<option value='https://www.andiemitchell.com/2016/08/'> August 2016 </option>
	<option value='https://www.andiemitchell.com/2016/07/'> July 2016 </option>
	<option value='https://www.andiemitchell.com/2016/06/'> June 2016 </option>
	<option value='https://www.andiemitchell.com/2016/05/'> May 2016 </option>
	<option value='https://www.andiemitchell.com/2016/04/'> April 2016 </option>
	<option value='https://www.andiemitchell.com/2016/03/'> March 2016 </option>
	<option value='https://www.andiemitchell.com/2016/02/'> February 2016 </option>
	<option value='https://www.andiemitchell.com/2016/01/'> January 2016 </option>
	<option value='https://www.andiemitchell.com/2015/12/'> December 2015 </option>
	<option value='https://www.andiemitchell.com/2015/11/'> November 2015 </option>
	<option value='https://www.andiemitchell.com/2015/10/'> October 2015 </option>
	<option value='https://www.andiemitchell.com/2015/09/'> September 2015 </option>
	<option value='https://www.andiemitchell.com/2015/08/'> August 2015 </option>
	<option value='https://www.andiemitchell.com/2015/07/'> July 2015 </option>
	<option value='https://www.andiemitchell.com/2015/05/'> May 2015 </option>
	<option value='https://www.andiemitchell.com/2015/04/'> April 2015 </option>
	<option value='https://www.andiemitchell.com/2015/01/'> January 2015 </option>
	<option value='https://www.andiemitchell.com/2014/12/'> December 2014 </option>
	<option value='https://www.andiemitchell.com/2014/11/'> November 2014 </option>
	<option value='https://www.andiemitchell.com/2014/10/'> October 2014 </option>
	<option value='https://www.andiemitchell.com/2014/09/'> September 2014 </option>
	<option value='https://www.andiemitchell.com/2014/08/'> August 2014 </option>
	<option value='https://www.andiemitchell.com/2014/07/'> July 2014 </option>
	<option value='https://www.andiemitchell.com/2014/06/'> June 2014 </option>
	<option value='https://www.andiemitchell.com/2014/04/'> April 2014 </option>
	<option value='https://www.andiemitchell.com/2014/03/'> March 2014 </option>
	<option value='https://www.andiemitchell.com/2014/02/'> February 2014 </option>
	<option value='https://www.andiemitchell.com/2014/01/'> January 2014 </option>
	<option value='https://www.andiemitchell.com/2013/12/'> December 2013 </option>
	<option value='https://www.andiemitchell.com/2013/11/'> November 2013 </option>
	<option value='https://www.andiemitchell.com/2013/10/'> October 2013 </option>
	<option value='https://www.andiemitchell.com/2013/09/'> September 2013 </option>
	<option value='https://www.andiemitchell.com/2013/08/'> August 2013 </option>
	<option value='https://www.andiemitchell.com/2013/07/'> July 2013 </option>
	<option value='https://www.andiemitchell.com/2013/06/'> June 2013 </option>
	<option value='https://www.andiemitchell.com/2013/05/'> May 2013 </option>
	<option value='https://www.andiemitchell.com/2013/04/'> April 2013 </option>
	<option value='https://www.andiemitchell.com/2013/03/'> March 2013 </option>
	<option value='https://www.andiemitchell.com/2013/02/'> February 2013 </option>
	<option value='https://www.andiemitchell.com/2013/01/'> January 2013 </option>
	<option value='https://www.andiemitchell.com/2012/12/'> December 2012 </option>
	<option value='https://www.andiemitchell.com/2012/11/'> November 2012 </option>
	<option value='https://www.andiemitchell.com/2012/10/'> October 2012 </option>
	<option value='https://www.andiemitchell.com/2012/09/'> September 2012 </option>
	<option value='https://www.andiemitchell.com/2012/08/'> August 2012 </option>
	<option value='https://www.andiemitchell.com/2012/07/'> July 2012 </option>
	<option value='https://www.andiemitchell.com/2012/06/'> June 2012 </option>
	<option value='https://www.andiemitchell.com/2012/05/'> May 2012 </option>
	<option value='https://www.andiemitchell.com/2012/04/'> April 2012 </option>
	<option value='https://www.andiemitchell.com/2012/03/'> March 2012 </option>
	<option value='https://www.andiemitchell.com/2012/02/'> February 2012 </option>
	<option value='https://www.andiemitchell.com/2012/01/'> January 2012 </option>
	<option value='https://www.andiemitchell.com/2011/12/'> December 2011 </option>
	<option value='https://www.andiemitchell.com/2011/11/'> November 2011 </option>
	<option value='https://www.andiemitchell.com/2011/10/'> October 2011 </option>
	<option value='https://www.andiemitchell.com/2011/09/'> September 2011 </option>
	<option value='https://www.andiemitchell.com/2011/08/'> August 2011 </option>
	<option value='https://www.andiemitchell.com/2011/07/'> July 2011 </option>
	<option value='https://www.andiemitchell.com/2011/06/'> June 2011 </option>
	<option value='https://www.andiemitchell.com/2011/05/'> May 2011 </option>
	<option value='https://www.andiemitchell.com/2011/04/'> April 2011 </option>
	<option value='https://www.andiemitchell.com/2011/03/'> March 2011 </option>
	<option value='https://www.andiemitchell.com/2011/02/'> February 2011 </option>
	<option value='https://www.andiemitchell.com/2011/01/'> January 2011 </option>
	<option value='https://www.andiemitchell.com/2010/12/'> December 2010 </option>
	<option value='https://www.andiemitchell.com/2010/11/'> November 2010 </option>
	<option value='https://www.andiemitchell.com/2010/10/'> October 2010 </option>
	<option value='https://www.andiemitchell.com/2010/09/'> September 2010 </option>
	<option value='https://www.andiemitchell.com/2010/08/'> August 2010 </option>
	<option value='https://www.andiemitchell.com/2010/07/'> July 2010 </option>
	<option value='https://www.andiemitchell.com/2010/06/'> June 2010 </option>

		</select>

<script type='text/javascript'>
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-5" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>

		</aside><aside id="search-6" class="widget widget_search"><h3 class="widget-title">Search</h3><form role="search" method="get" id="searchform" class="searchform" action="https://www.andiemitchell.com/" >
    <div class="searchbox">
    <input class="textbox" type="text" value="SEARCH" name="s" id="s" onfocus="if (this.value == 'SEARCH') {this.value = '';}" onblur="if (this.value == '') {this.value = 'SEARCH';}"/>
    </div>
    </form></aside>		</div><!-- #secondary -->
	</div><!-- #main .wrapper -->

</div><!-- #page -->

    <div id="secondaryfooter">
        <div class="secondaryfooter">
            <div class="widget"><h3 class="widget-title">Featured In</h3><div class="menu-press-container"><ul id="menu-press" class="menu"><li id="menu-item-15371" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15371"><a>Good Morning America</a></li>
<li id="menu-item-15372" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15372"><a>Dr. Oz</a></li>
<li id="menu-item-15373" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15373"><a>The Better Show</a></li>
<li id="menu-item-15374" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15374"><a>The View</a></li>
<li id="menu-item-15375" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15375"><a>The New York Post</a></li>
<li id="menu-item-15376" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15376"><a>The Daily Maily</a></li>
<li id="menu-item-15377" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15377"><a>People Magazine</a></li>
<li id="menu-item-15378" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15378"><a>Marie Claire</a></li>
<li id="menu-item-15379" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15379"><a>Elle</a></li>
<li id="menu-item-15380" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15380"><a>Shape</a></li>
<li id="menu-item-15381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15381"><a>Glamour</a></li>
<li id="menu-item-15382" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15382"><a>Southern Living</a></li>
<li id="menu-item-15383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15383"><a>Health Magazine</a></li>
</ul></div></div>        </div>
    </div>
<footer id="colophon" role="contentinfo">
    <div class="site-info">
        <li>Andie Mitchell &#169; 2020</li>
        <div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-15368" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15368"><a href="https://www.andiemitchell.com/about/">About</a></li>
<li id="menu-item-15367" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15367"><a href="https://www.andiemitchell.com/favorite">Shop</a></li>
<li id="menu-item-15369" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15369"><a href="https://www.andiemitchell.com/contact-me/">Contact</a></li>
<li id="menu-item-15370" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15370"><a href="https://www.andiemitchell.com/privacy-policy/">Privacy Policy</a></li>
</ul></div>        <li>
            design by <a target="_blank" href="http://whiteoakcreative.com/" title="White Oak Creative">White
                Oak Creative</a></li>
    </div>
    <!-- .site-info -->
</footer><!-- #colophon -->
<div id="footerwidget">

            <div class="footerwidget">
            <div class="widget"><h3 class="widget-title">@andiemitchell</h3>			<div class="textwidget"><!-- LightWidget WIDGET --><script src="//lightwidget.com/widgets/lightwidget.js"></script><iframe src="//lightwidget.com/widgets/5658e1e775bb55cfae67abe44b6bf65d.html" id="lightwidget_5658e1e775" name="lightwidget_5658e1e775"  scrolling="no" allowtransparency="true" class="lightwidget-widget" style="width: 100%; border: 0; overflow: hidden;"></iframe></div>
		</div>        </div>
    </div>
<div style="display: none;"><div id="boxzilla-box-15314-content"><p><img class="alignnone size-full wp-image-15385" src="https://www.andiemitchell.com/wp-content/uploads/2016/08/subscribe.png" alt="subscribe" width="601" height="101" /></p>
<p>Don&#8217;t want to miss out on any new content?<br />
Sign up today to receive weekly updates right to your inbox!</p>
<form action="//andiemitchell.us12.list-manage.com/subscribe/post?u=bc99a5d0504383d1d8f673a0c&amp;id=67504c4890" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<div class="mc-field-group">
	<input type="email" size="40" value="ENTER YOUR EMAIL" name="EMAIL" class="required email" id="mce-EMAIL" onfocus="if(this.value==this.defaultValue)this.value='';" onblur="if(this.value=='')this.value=this.defaultValue;" >
</div>
<div class="mc-field-group">
	<input type="text" size="40" value="ENTER YOUR NAME" name="FNAME" class="" id="mce-FNAME" onfocus="if(this.value==this.defaultValue)this.value='';" onblur="if(this.value=='')this.value=this.defaultValue;" >
</div>
<div id="mce-responses" class="clear">
<div class="response" id="mce-error-response" style="display:none"></div>
<div class="response" id="mce-success-response" style="display:none"></div>
</p></div>
<p>    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups--></p>
<div style="position: absolute; left: -5000px;"><input type="text" name="b_bc99a5d0504383d1d8f673a0c_67504c4890" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</p></div>
</form>
</div></div><script>
(function (w, d) {
	var s = d.createElement('script');
	s.src = "https://dstik9906m659.cloudfront.net/eVIfRVUUblIfRlskRCEyUu.js";
	s.defer = true;
	d.body.appendChild(s);
})(window, document);
</script>
<script>
    jQuery(document).ready(function () {
		jQuery.post('https://www.andiemitchell.com?ga_action=googleanalytics_get_script', {action: 'googleanalytics_get_script'}, function(response) {
			var s = document.createElement("script");
			s.type = "text/javascript";
			s.innerHTML = response;
			jQuery("head").append(s);
		});
    });
</script><link rel='stylesheet' id='wprm-public-css'  href='https://www.andiemitchell.com/wp-content/plugins/wp-recipe-maker/dist/public-modern.css?ver=5.11.1' type='text/css' media='all' />
<link rel='stylesheet' id='wprmp-public-css'  href='https://www.andiemitchell.com/wp-content/plugins/wp-recipe-maker-premium/dist/public-pro.css?ver=5.11.1' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var jpibfi_options = {"hover":{"siteTitle":"Andie Mitchell","image_selector":".jpibfi_container img","disabled_classes":"wp-smiley;nopin","enabled_classes":"","min_image_height":0,"min_image_height_small":0,"min_image_width":0,"min_image_width_small":0,"show_on":"[front],[home],[single],[page],[archive],[search],[category]","disable_on":"","show_button":"hover","button_margin_bottom":20,"button_margin_top":20,"button_margin_left":20,"button_margin_right":20,"button_position":"top-left","description_option":["post_title"],"transparency_value":0.1499999999999999944488848768742172978818416595458984375,"pin_image":"default","pin_image_button":"square","pin_image_icon":"circle","pin_image_size":"normal","custom_image_url":"https:\/\/www.andiemitchell.com\/wp-content\/uploads\/2016\/08\/pinit.png","scale_pin_image":false,"pin_linked_url":true,"pinLinkedImages":false,"pinImageHeight":54,"pinImageWidth":54,"scroll_selector":"","support_srcset":false}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.andiemitchell.com/wp-content/plugins/jquery-pin-it-button-for-images/js/jpibfi.client.js?ver=3.0.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var socialWarfare = {"addons":[],"post_id":"18259","variables":{"emphasizeIcons":false,"powered_by_toggle":false,"affiliate_link":"https:\/\/warfareplugins.com"},"floatBeforeContent":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.andiemitchell.com/wp-content/plugins/social-warfare/assets/js/script.min.js?ver=4.0.1'></script>
<script type='text/javascript' src='https://www.andiemitchell.com/wp-includes/js/comment-reply.min.js?ver=5.2.7'></script>
<script type='text/javascript' src='https://www.andiemitchell.com/wp-content/themes/twentytwelve/js/navigation.js?ver=20140711'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var boxzilla_options = {"testMode":"","boxes":[{"id":15314,"icon":"&times;","content":"","css":{"background_color":"#2f2f2f","color":"#ffffff","width":500,"position":"center"},"trigger":{"method":"percentage","value":65},"animation":"slide","cookie":{"triggered":0,"dismissed":48},"rehide":true,"position":"center","screenWidthCondition":{"condition":"larger","value":60},"closable":true,"post":{"id":15314,"title":"Subscribe","slug":"subscribe"}}]};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.andiemitchell.com/wp-content/plugins/boxzilla/assets/js/script.min.js?ver=3.2.22'></script>
<script type='text/javascript' src='https://www.andiemitchell.com/wp-includes/js/wp-embed.min.js?ver=5.2.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wprm_public = {"settings":{"features_comment_ratings":true},"home_url":"https:\/\/www.andiemitchell.com\/","permalinks":"\/%postname%\/","ajax_url":"https:\/\/www.andiemitchell.com\/wp-admin\/admin-ajax.php","nonce":"b09b7234dc","api_nonce":"4f4ff333d2","translations":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.andiemitchell.com/wp-content/plugins/wp-recipe-maker/dist/public-modern.js?ver=5.11.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wprmp_public = {"endpoints":[],"settings":{"recipe_template_mode":"modern","features_adjustable_servings":true,"adjustable_servings_round_to_decimals":"2","features_comment_ratings":true,"features_user_ratings":false,"user_ratings_force_comment":"never","servings_changer_display":"tooltip_slider","template_ingredient_list_style":"disc","template_instruction_list_style":"decimal","template_color_icon":"#343434"},"timer":{"sound_dir":"https:\/\/www.andiemitchell.com\/wp-content\/plugins\/wp-recipe-maker-premium\/dist\/","text":{"start_timer":"Click to Start Timer"},"icons":{"pause":"<svg xmlns=\"http:\/\/www.w3.org\/2000\/svg\" xmlns:xlink=\"http:\/\/www.w3.org\/1999\/xlink\" x=\"0px\" y=\"0px\" width=\"24px\" height=\"24px\" viewBox=\"0 0 24 24\"><g ><path fill=\"#fffefe\" d=\"M9,2H4C3.4,2,3,2.4,3,3v18c0,0.6,0.4,1,1,1h5c0.6,0,1-0.4,1-1V3C10,2.4,9.6,2,9,2z\"\/><path fill=\"#fffefe\" d=\"M20,2h-5c-0.6,0-1,0.4-1,1v18c0,0.6,0.4,1,1,1h5c0.6,0,1-0.4,1-1V3C21,2.4,20.6,2,20,2z\"\/><\/g><\/svg>","play":"<svg xmlns=\"http:\/\/www.w3.org\/2000\/svg\" xmlns:xlink=\"http:\/\/www.w3.org\/1999\/xlink\" x=\"0px\" y=\"0px\" width=\"24px\" height=\"24px\" viewBox=\"0 0 24 24\"><g ><path fill=\"#fffefe\" d=\"M6.6,2.2C6.3,2,5.9,1.9,5.6,2.1C5.2,2.3,5,2.6,5,3v18c0,0.4,0.2,0.7,0.6,0.9C5.7,22,5.8,22,6,22c0.2,0,0.4-0.1,0.6-0.2l12-9c0.3-0.2,0.4-0.5,0.4-0.8s-0.1-0.6-0.4-0.8L6.6,2.2z\"\/><\/g><\/svg>","close":"<svg xmlns=\"http:\/\/www.w3.org\/2000\/svg\" xmlns:xlink=\"http:\/\/www.w3.org\/1999\/xlink\" x=\"0px\" y=\"0px\" width=\"24px\" height=\"24px\" viewBox=\"0 0 24 24\"><g ><path fill=\"#fffefe\" d=\"M22.7,4.3l-3-3c-0.4-0.4-1-0.4-1.4,0L12,7.6L5.7,1.3c-0.4-0.4-1-0.4-1.4,0l-3,3c-0.4,0.4-0.4,1,0,1.4L7.6,12l-6.3,6.3c-0.4,0.4-0.4,1,0,1.4l3,3c0.4,0.4,1,0.4,1.4,0l6.3-6.3l6.3,6.3c0.2,0.2,0.5,0.3,0.7,0.3s0.5-0.1,0.7-0.3l3-3c0.4-0.4,0.4-1,0-1.4L16.4,12l6.3-6.3C23.1,5.3,23.1,4.7,22.7,4.3z\"\/><\/g><\/svg>"}},"recipe_submission":{"max_file_size":8388608,"text":{"image_size":"The image file is too large","drop_image":"Drop an image"}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.andiemitchell.com/wp-content/plugins/wp-recipe-maker-premium/dist/public-pro.js?ver=5.11.1'></script>
<script async="async" type='text/javascript' src='https://www.andiemitchell.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.5'></script>
<div class="swp_social_panelSide swp_floating_panel swp_social_panel swp_ swp_default_full_color swp_individual_full_color swp_other_full_color slide swp_float_left" data-min-width="1100" data-float-color="#ffffff" data-float="left" data-float-mobile="none" data-transition="slide" data-post-id="18259" ><div class="nc_tweetContainer swp_share_button swp_pinterest" data-network="pinterest"><a rel="nofollow noreferrer noopener" class="nc_tweet swp_share_link noPop" onClick="var e=document.createElement('script');
						e.setAttribute('type','text/javascript');
						e.setAttribute('charset','UTF-8');
						e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);
						document.body.appendChild(e);
					" ><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_pinterest_icon"></i><span class="swp_share">Pin</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_facebook" data-network="facebook"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.andiemitchell.com%2Fcheesy-beef-taco-skillet%2F" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.andiemitchell.com%2Fcheesy-beef-taco-skillet%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_twitter" data-network="twitter"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=Cheesy+Beef+Taco+Skillet&url=https%3A%2F%2Fwww.andiemitchell.com%2Fcheesy-beef-taco-skillet%2F&via=andiemmitchell" data-link="https://twitter.com/intent/tweet?text=Cheesy+Beef+Taco+Skillet&url=https%3A%2F%2Fwww.andiemitchell.com%2Fcheesy-beef-taco-skillet%2F&via=andiemmitchell"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div></div><style type="text/css">.wprm-recipe-template-compact {
    margin: 20px auto;
    background-color: #fafafa; /* wprm_background type=color */
    font-family: Helvetica, sans-serif; /* wprm_main_font_family type=font */
    font-size: 0.9em; /* wprm_main_font_size type=font_size */
    line-height: 1.5em; /* wprm_main_line_height type=font_size */
    color: #333333; /* wprm_main_text type=color */
    max-width: 650px; /* wprm_max_width type=size */
}
.wprm-recipe-template-compact a {
    color: #3498db; /* wprm_link type=color */
}
.wprm-recipe-template-compact p, .wprm-recipe-template-compact li {
    font-family: Helvetica, sans-serif; /* wprm_main_font_family type=font */
    font-size: 1em !important;
    line-height: 1.5em !important; /* wprm_main_line_height type=font_size */
}
.wprm-recipe-template-compact li {
    margin: 0 0 0 32px !important;
    padding: 0 !important;
}
.rtl .wprm-recipe-template-compact li {
    margin: 0 32px 0 0 !important;
}
.wprm-recipe-template-compact ol, .wprm-recipe-template-compact ul {
    margin: 0 !important;
    padding: 0 !important;
}
.wprm-recipe-template-compact br {
    display: none;
}
.wprm-recipe-template-compact .wprm-recipe-name,
.wprm-recipe-template-compact .wprm-recipe-header {
    font-family: Helvetica, sans-serif; /* wprm_header_font_family type=font */
    color: #000000; /* wprm_header_text type=color */
    line-height: 1.3em; /* wprm_header_line_height type=font_size */
}
.wprm-recipe-template-compact h1,
.wprm-recipe-template-compact h2,
.wprm-recipe-template-compact h3,
.wprm-recipe-template-compact h4,
.wprm-recipe-template-compact h5,
.wprm-recipe-template-compact h6 {
    font-family: Helvetica, sans-serif; /* wprm_header_font_family type=font */
    color: #000000; /* wprm_header_text type=color */
    line-height: 1.3em; /* wprm_header_line_height type=font_size */
    margin: 0 !important;
    padding: 0 !important;
}
.wprm-recipe-template-compact .wprm-recipe-header {
    margin-top: 1.2em !important;
}
.wprm-recipe-template-compact h1 {
    font-size: 2em; /* wprm_h1_size type=font_size */
}
.wprm-recipe-template-compact h2 {
    font-size: 1.8em; /* wprm_h2_size type=font_size */
}
.wprm-recipe-template-compact h3 {
    font-size: 1.2em; /* wprm_h3_size type=font_size */
}
.wprm-recipe-template-compact h4 {
    font-size: 1em; /* wprm_h4_size type=font_size */
}
.wprm-recipe-template-compact h5 {
    font-size: 1em; /* wprm_h5_size type=font_size */
}
.wprm-recipe-template-compact h6 {
    font-size: 1em; /* wprm_h6_size type=font_size */
}.wprm-recipe-template-compact {
	border-style: solid; /* wprm_border_style type=border */
	border-width: 1px; /* wprm_border_width type=size */
	border-color: #777777; /* wprm_border type=color */
	border-radius: 0px; /* wprm_border_radius type=size */
	padding: 10px;
}.wprm-recipe-template-snippet-basic-buttons {
    font-family: inherit; /* wprm_font_family type=font */
    font-size: 0.9em; /* wprm_font_size type=font_size */
    text-align: center; /* wprm_text_align type=align */
    margin-top: 0px; /* wprm_margin_top type=size */
    margin-bottom: 10px; /* wprm_margin_bottom type=size */
}
.wprm-recipe-template-snippet-basic-buttons a  {
    margin: 5px; /* wprm_margin_button type=size */
    margin: 5px; /* wprm_margin_button type=size */
}

.wprm-recipe-template-snippet-basic-buttons a:first-child {
    margin-left: 0;
}
.wprm-recipe-template-snippet-basic-buttons a:last-child {
    margin-right: 0;
}</style><script type="text/javascript"> var swp_nonce = "5fad353057";
function parentIsEvil() { var html = null; try { var doc = top.location.pathname; } catch(err){ }; if(typeof doc === "undefined") { return true } else { return false }; }; if (parentIsEvil()) { top.location = self.location.href; };var url = "https://www.andiemitchell.com/cheesy-beef-taco-skillet/";if(url.indexOf("stfi.re") != -1) { var canonical = ""; var links = document.getElementsByTagName("link"); for (var i = 0; i < links.length; i ++) { if (links[i].getAttribute("rel") === "canonical") { canonical = links[i].getAttribute("href")}}; canonical = canonical.replace("?sfr=1", "");top.location = canonical; console.log(canonical);};var swpFloatBeforeContent = false; var swp_ajax_url = "https://www.andiemitchell.com/wp-admin/admin-ajax.php"; var swp_post_id = "18259";var swpClickTracking = false;</script><script type='text/javascript' src='https://stats.wp.com/e-202024.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.3',blog:'115761318',post:'18259',tz:'-4',srv:'www.andiemitchell.com'} ]);
	_stq.push([ 'clickTrackerInit', '115761318', '18259' ]);
</script>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js"></script>
<script type="text/javascript" src="https://www.andiemitchell.com/wp-content/themes/Magnolia-AM/js/scripts.js"></script>
<script src="https://use.fontawesome.com/dce301283e.js"></script>
<script src="https://use.typekit.net/dnr2kyd.js"></script>
<script>try {
        Typekit.load({async: true});
    } catch (e) {
    }</script>
</body>
</html>
<!-- Page generated by LiteSpeed Cache 3.0.8.3 on 2020-06-13 05:35:03 -->